eclipse运行tomcat时提示Cannot create a server using the selected type


在Ubuntu系统上 ,通过sudo apt-get install tomcat6安装tomcat服务器之后,已经能够正常作为服务运行,但是在使用eclipse开发的时候,无法将工程运行在tomcat服务器上,提示Cannot create a server using the selected type

造成这个问题的原因是ubuntu版本的tomcat将conf和bin文件夹分别放置在不同的路径下,通过以下方法可以解决上面的问题。

打开终端(terminal),然后执行下面的命令:

Code:
sudo apt-get install tomcat6
cd /usr/share/tomcat6
sudo ln -s /var/lib/tomcat6/conf conf
sudo ln -s /etc/tomcat6/policy.d/03catalina.policy conf/catalina.policy
sudo ln -s /var/log/tomcat6 log
sudo chmod -R 777 /usr/share/tomcat6/conf

配置 eclipse. 设置Tomcat安装目录(TOMCAT_HOME)为 /usr/share/tomcat6

问题解决!

Advertisements

eclipse运行tomcat时提示Cannot create a server using the selected type》上有3条评论

发表评论

Fill in your details below or click an icon to log in:

WordPress.com Logo

You are commenting using your WordPress.com account. Log Out / 更改 )

Twitter picture

You are commenting using your Twitter account. Log Out / 更改 )

Facebook photo

You are commenting using your Facebook account. Log Out / 更改 )

Google+ photo

You are commenting using your Google+ account. Log Out / 更改 )

Connecting to %s