分类目录归档:Flex

执行RDS命令时出错。状态代码: 404,原因: Not found


最近在做一个flex的项目,使用到了Flash Builder 4 for eclipse 插件。

通过该IDE创建了一个Flex Project,测试的时候发现,flex能够通过amf远程调用到后台Service的对象。但是在执行连接数据/服务…功能的时候提示:

RDS服务器消息:
执行RDS命令时出错。状态代码: 404,原因: Not found

出现这种错误的原因是flash builder 4 for eclipse创建的flex 项目的serverContextRoot设置不正确,通过修改工程根目录下的.flexProperties文件中的serverContextRoot=”工程名称” serverRootURL=”http://localhost:8080″后,问题解决。

真不知道adobe是怎么搞的,Flash Builder 4 for eclipse plugins只能支持eclipse 3.5,在eclipse 3.6上创建项目都会失败。
按照官方要求使用eclipse 3.5然后安装Flash Builder 4插件吧,结果默认创建的工程还有问题。

How to install the FlashBuilder for Linux


Adobe最近宣布,放弃新版Flex4 for eclipse插件Linux平台的开发,目前仅仅支持windows, mac平台。

之前提供的flex3 for eclipse plugins也不提供下载,并且仅能用到2010年12月份。

Adobe居然建议使用open source的flex sdk进行flex开发。晕!这是提高flex在linux的开发门槛阿。

具体的信息看http://labs.adobe.com/technologies/flex/flexbuilder_linux/吧!

不甘心,上网找了好一阵子,有推荐安装emacs插件,实现代码提示功能,然后通过插件实现快速编译的。——这种方法我不熟练,还是期望能够在eclipse里开发。毕竟不仅仅是写flex代码,还需要进行Java的开发。

另外还有推荐安装FDT4 for eclipse plugins的,这个插件确实能够支持flex的开发。看了一下,操作系统应该和Flash Builder 4还是有一些差别的,而我在公司的开发机用的是Flash Builder 4 for eclipse plugins,不想再熟悉另外一套插件了。所以也没有试验了。

最后一种方法,也是我目前使用的方法,在http://code.google.com/p/fb4linux/ ,首先下载四个FB4Linux文件,然后执行cat FB4Linux* >FB4Linux.tar.bz2

图文结合的安装说明(英文):Installing FB4Linux in Eclipse

解压缩这个文件到一个目录,比如我解压缩在/opt/Adobe/flex4Build/

接下来打开eclipse,然后Help->Software Updates->Manage Configuration(如果没有这个菜单,选择Window->Preferences->General->Capabilities-> 选中Classis Update) ->右击树列表空白除->add->extension location->select the path:/opt/Adobe/flex4Build/ :/home/feiy/FlexBuilder4Linux

点击OK,然后重启eclipse,之后应该就能看到flex builder已经正确安装了。但是还需要自己选择以下flex sdk的目录。

更多信息请参考:http://code.google.com/p/fb4linux/wiki/HowToInstall

other

if can’t run/debug app,do:
mkdir -p ~/.macromedia/Flash_Player/#Security/FlashPlayerTrust

if got:
An ActionScript error has occurred:
SecurityError: Error #2148: SWF file file:///home/jupiter/projects/temp/TestProject/bin-debug/TestProject.swf cannot access local resource file:///home/jupiter/projects/temp/TestProject/bin-debug/textLayout_1.0.0.549.swf. Only local-with-filesystem and trusted local SWF files may access local resources.
at flash.net::URLStream/load()
at flash.net::URLLoader/load()
at mx.core::CrossDomainRSLItem/load()[E:\dev\trunk\frameworks\projects\framework\src\mx\core\CrossDomainRSLItem.as:235]
at mx.core::RSLListLoader/loadNext()[E:\dev\trunk\frameworks\projects\framework\src\mx\core\RSLListLoader.as:184]
at mx.core::RSLListLoader/load()[E:\dev\trunk\frameworks\projects\framework\src\mx\core\RSLListLoader.as:156]
at mx.preloaders::Preloader/initialize()[E:\dev\trunk\frameworks\projects\framework\src\mx\preloaders\Preloader.as:279]
at mx.managers::SystemManager/http://www.adobe.com/2006/flex/mx/internal::initialize()[E:\dev\trunk\frameworks\projects\framework\src\mx\managers\SystemManager.as:1927]
at mx.managers::SystemManager/initHandler()[E:\dev\trunk\frameworks\projects\framework\src\mx\managers\SystemManager.as:2421]
try to add the eclipse workspace path to ~/.macromedia/Flash_Player/#Security/FlashPlayerTrust/flexbuilder_plugin.cfg